Problems with login in to ODK-X Server web-ui. Incorrect username or password

Hi @W_Brunette ,

I’m not using cloud-based setup but manual-server setup in my local system and as per your suggestion, i’ve updated the uid and added one user in group 503. But, still i’m not able to login at with same error as Incorrect username or password.

The screenshot attached below is depicting all 3 users i’ve added.

The following is the error after running the command docker logs sync-web-ui ID

2021-04-08 23:33:56.355  INFO 7 --- [nio-8080-exec-2] bServiceDelegatingAuthenticationProvider : Received an exception when getting granted roles

2021-04-08 23:33:56.355 INFO 7 — [nio-8080-exec-2] bServiceDelegatingAuthenticationProvider : Received 404
2021-04-08 23:33:56.355 INFO 7 — [nio-8080-exec-2] bServiceDelegatingAuthenticationProvider : Received <!doctype html>HTTP Status 404 – Not Foundbody {font-family:Tahoma,Arial,sans-serif;} h1, h2, h3, b {color:white;background-color:#525D76;} h1 {font-size:22px;} h2 {font-size:16px;} h3 {font-size:14px;} p {font-size:12px;} a {color:black;} .line {height:1px;background-color:#525D76;border:none;}

HTTP Status 404 – Not Found

Type Status Report

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

Apache Tomcat/8.5.65

It looks like LDAP does not like how something is setup. Try logging in through a phone or mobile device and check the logs in sync-endpoint docker container. The sync-endpoint often gives better messages about the problems.

1 Like

Hi @W_Brunette ,

I’ve cleaned my docker by deleting all the earlier images. Again started from mvn clean install then pulling all the fresh images. Even then, i’m facing the same issue of incorrect name or password at

Also i’m attaching the docker logs result of sync-endpoint container. docker logs of sync-endpoint container.txt (12.8 KB)

Here, i’ve followed the documentation (Manual ODK-X Server setup) step-by-step and not able to understand the reason behind this.


@Prashant sorry you are having problems. We are hoping to improve the instructions soon.

did you docker system prune? As recreating images does not necessarily clean the volumes. Shut everything down and run system prune until there is nothing left. That way you are sure you are starting fresh.


@Prashant did you finally succeed. I have a similar setup though ubuntu 18.04 and am stuck
I need guidance.
local setup that is

1 Like

Hi @hissdev,

Initially, I was trying to setup the ODK-X server on local system on Windows 10. I was able to login https://[localhost]:40000 and add user to groups, but couldn’t login at http://[localhost] due to incorrect username and password error. I was not able to find the reason behind this.
Although, one of my friend followed the same documentation for local server setup on a linux system and successfully logged in at http://[localhost]. Interestingly, Me and my friend followed the same documentation Setup ODK-X Sync Endpoint Manually — ODK-X Docs. :smile:

1 Like

Make sure you have at least one user assigned to group 503 (synchronize tables).


Another idea restart the docker stack as sometimes problems are caused by caching of the LDAP user information in the processes.



My app is running smoothly using ODK-X Services and ODK-X Survey tools in the smartphone. The issue with server-sync up got resolved, a simple stack-up and stack-down docker did the job. Thanks for helping out here.
Although, now I’m focusing on to create different user groups and to define their rules. I’ve little confusion regarding how to go ahead. Do I need to use already available groups in phpLDAPadmin (at https://localhost:40000) or should i create new groups, then how to decide their roles? I’ve seen some discussions on the forum, where they have used some excel (such as Senado9.csv (1.0 KB)) files to define the groups and roles. Help me here to clear this doubt.

Note:- I’ve gone through "Data Permission Filters" topic from the documentation, but couldn’t understand about how to create new rules and groups.

1 Like

Hi @Prashant!

The info on creating new groups and assigning users is here:

1 Like

Thanks, @elmps2018 for replying.

I’ve taken the help of the documentation that you mentioned above to make the new users and assign them in the groups. But, I am more curious to make my own groups and how to decide the user rights for a specific group? Or, I’ll have to use already available groups at 40000 port of localhost.

1 Like

@Prashant the documentation explains how to make your own groups, but what groups you make will definitely depend on how you are implementing. As an example, when we did data collection, we had teams in different states that were visiting households. We didn’t know which team member would visit a particular household, but we did know which (state-based) team. So we set up a group for each team and assigned permission so only the team members in that state could collect data for households in that state.

1 Like

@elmps2018, from the documentation, I was able to understand how to create new users, new groups and how to assign users to a specific group. But, I couldn’t find any documentation regarding how to assign permission in a new group. Currently, already available groups (Gid Number 500 to 506) has some specific permissions, but how to assign permissions to a new group. I hope, you understand my dilemma.

Hi @Prashant I get what you are saying about the groups! There may be something about setting up the groups where you pick permissions but I am not immediately seeing it in the docs… @linl33 or @Jeff_Beorse or @W_Brunette do you know?

1 Like

@Prashant once you have the groups you can use them to apply data permission filters in addition to the built in roles. Check out this documentation section.

Specifically every row can have a different group assigned to it with different levels of permissions. Check out: Data Permission Filters — ODK-X Docs

There is also table level security:



I faced the login problem too after manually set up of Sync Endpoint. Every thing went fine except I could not login into web-ui. I reinstalled the system almost five times after removing all files and docker images with no success. But then i came across a post which suggested removing mysql-test module together with its dependencies from pom.xml file in the sync-endpoint directory before i run mvn clean install in step 5. After that everything went fine. Could this be the cause of the problem?


1 Like

@John_Mduda yes it could be causing a problem. The initialization script now uses this command

mvn -pl org.opendatakit:sync-endpoint-war,org.opendatakit:sync-endpoint-docker-swarm,org.opendatakit:sync-endpoint-common-dependencies clean install -DskipTests

Where the command explicitly lists the sub-projects that need to run to not run others.


Okay, so I have gone through this post thoroughly but nothing in there has actually helped. I am facing the same login problem with “incorrect username or password” message.

I followed the instructions carefully and could successfully setup ODK-X Sync Endpoint on Digital Ocean droplet. I am able to login to admin interface just fine. I followed the instructions and created 2 users - one belonging to gidNumber=501 and other gidNumber=503. I can use these newly created users to login to the same admin interface, but I can not login to the web-ui. Here’s is what I am getting in the logs -

The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.</p><hr class="line" /><h3>Apache Tomcat/8.5.73</h3></body></html>
2022-02-08 10:58:46.078  INFO 7 --- [nio-8080-exec-9] bServiceDelegatingAuthenticationProvider : Logging in with http://sync:8080/odktables/{appId}/privilegesInfo
2022-02-08 10:58:46.093  INFO 7 --- [nio-8080-exec-9] bServiceDelegatingAuthenticationProvider : Received an exception when getting granted roles
2022-02-08 10:58:46.096  INFO 7 --- [nio-8080-exec-9] bServiceDelegatingAuthenticationProvider : Received 404

Since the last post was several months back, I wonder if something has changed and if there is more information available to fix this problem. Thanks.

1 Like

Mandy, is the user in the “synchronize tables” normally number 503 group? if not they might not have been granted access to the system.

Also if there is an error in your configuration you can use
https:///odktables/default/privilegesInfo in your web browser and it will show problems with group membership if they exist.