Delete unwanted tables?

What is the problem? Please be detailed.

To get everything up and running, I uploaded the Geotagger example to my sync-endpoint instance. Logging on to the web-ui I can delete the ‘rows’ but I don’t seem to be able to delete the manifest, so the blank form keeps re-syncing to my device. I can remove it from the device by deleting it in ODK Tables but as soon as I re-sync/reset the app server, it comes back again?

What ODK tool and version are you using? And on what device and operating system version?

ODK2 on Ubuntu 18.04 and Android devices

Hi @ghare!

So if you want to remove the example (Geotagger), it needs to be off both the tablet and the server (otherwise as you note it will keep syncing back down).

See resetting the app server for how to do this (this is how you change the set of tables and data – make sure you have downloaded anything you want to save):


Hi Caroline,

I have cleared the device using ‘grunt clean’ but when I try to reset the app server from the device I get a ‘Device Configuration Failure’ window. If understand it correctly, there needs to be a form/table of some description on the device to make it sync with the server, it won’t just wipe everything?

I realised I hadn’t cleaned the App directory completely, so the ‘grunt adbpush’ was sending the example stuff out again each time.

However, I have cleaned it now and when I do the ‘grunt adbpush’, it only sends my survey to the device. When I do the ‘App Server Reset’ it only sends my app details. But it still doesn’t seem to be deleting the old tables from the sync-endpoint. As soon as I sync the device again, the old stuff is sent from the server, back onto the device??



Dear @ghare,

Ah-ha, okay, so the reset app server doesn’t delete everything, but ODK Suitcase can. See How to remove the form on the ODK2 cloud endpoint server?
This is what we used when totally wiping the server. Use with caution!



Suitcase worked at treat. Thanks for your help.