"Internal Server Error (out of quota?)" error (and solution!)

We have been working on an ODK 2.0 project for a while and had originally set up an Aggregate server on Google App Engine. We were just adding another tablet to our workflow today, and when we were at the step to set up the link to the server in ODK services, after entering the url, user name, and passwords, when we got to verify user permissions, then got the error “Internal Server Error (out of quota?)”

Took us a while to figure out what the error was (everything is happy now) but I wanted to post this in case anyone else has the same problem, since when we googled “Internal Server Error (out of quota?)” there were zero results.

It turns out we had downloaded rev214 of the tools to the tablet. We had been working with rev208 of the tools and the corresponding version of aggregate. “Internal Server Error (out of quota?)” translated to “You have different versions of the software on your tablet and server.” When deleted the rev214 and downloaded rev208 to the tablet instead, everything worked.

So FYI for anyone who runs into the same problem–and if the error message is something coming from ODK not App Engine, a suggestion for a more informative error message :slight_smile:

Thanks for posting the error and solution @elmps2018!

I have a created an issue about improving error handling in future versions!

A post was split to a new topic: Internal server error out of quota


I have also got this error and the problem is as mentioned because of the old versions of odk-x tools, however the surveyors are out to the fields and now there is no way to upgrade all those devices, Is there an alternative solution for this problem?


Is it definitely the case you have different versions? Are they different versions across tablets (e.g. tablet1 has rev208, tablet2 rev210, etc.) or are different versions happening between app-designer/the server/some central component and the tablets? Can you tell us what versions?

Well, I have checked the versions and it is same across all the devices, It was all working fine in the beginning but now it doesnt work for the users who are added to the site_admins, administer_tables, super_user_table groups in sync endpoint.

In the webUi I can log in to the system but I cannot see the roles and users tab giving me the 500 error.
and of course cant be authenticated in ODK-X survey app.

So it sounds like there are different versions between the tablets and the app-designer/the server. Can you tell us what versions are on each?

Does everything work if added as a normal user but not the other types of users?

2 posts were split to a new topic: External import error


I am reopening this thread because we tried a lot to solve the issue with the current solutions but to no avail.

As for the tools version everything is the same only the app designer is used in two versions 2.1.0 and 2.1.3. This should not be that of a big deal I guess.

And the same form works in some devices but giving “Out of quota” error in few.

The app versions used in the survey are as follows

ODK Survey: v2.1.0
ODK Tables: v2.1.0
ODK Services: v2.1.0

The concern is, if it is a real error, then why not thrown in all devices and if it is not then why those few devices give error.

a little help will be much appreciated.

@elmps2018, @W_Brunette


I would suggest getting the logs from one of the tablets that works and one of the tablets that has the error; the logs should be in the output folder within opendatakit. You may want to sit there and try to do the same thing on the two tablets at the same time right before getting the logs so it will be the latest part of the logs. If you compare them, there may be an error or at least a clear difference in what they are doing; if you want to share any share-able bits we can take a look.


Taking your advice of checking the logs, I finally figured out what (Out of quota) really meant (at least in our scenario ).

One of our forms has a field for phone number and that mistakenly was typed as integer, so when the surveyor entered the 10 digit phone number, the SQLITE was accepting it but when we were trying to sync the data, since the Postgres does not accept 10 digits for an integer, so the Internal server error (Out of quota ? ) basically meant was that there is some problem with your data that does not fit with the server.

Thank you for your support.