ODK 2.0 - Application Designer Not Loading Sample Application

Installed Application Designer (2.1.1) from https://github.com/opendatakit/app-designer/releases/tag/2.1.1 . - on MacOS 10.14.2.

Installed:
Java version 1.8.0_202-ea
NodeJS: npm --version 6.4.1
grunt-cli v1.3.2
Full Android Studio

Unzipped app-designer-2.1.1 folder is in the Home folder

Chrome loads http://localhost:8000/index.html but will not load the sample application downloaded with the ODK file. Can’t access any sample forms, tables etc.

Screenshot attached.

Thanks for any help with this.

Hi @Cairo!

So a few things to check. First, were you launching from the terminal window from the directory where the app designer is? See:
https://docs.opendatakit.org/odk2/app-designer-launching/
for instructions on that. Were there any errors when you did?

Can you go to file browser (tab in chrome up there) and see the sample application files?

Did you make sure to follow step 6 onwards for setting up SDK here:
https://docs.opendatakit.org/odk2/app-designer-prereqs/#android-sdk

Did you change or delete any of the files after downloading?

Not sure which (if any of these) is the issue but hopefully will figure it out working through these!

Best,
Caroline

Hi Caroline,

Many thanks for your email. I have followed the steps that you advised and added my answers below, as I am still unable to load the demo application.

Hi Caroline,

When I run grunt the web page opens (as per my screenshot) and the terminal running grunt reports:

Last login: Fri Jan 25 14:52:42 on ttys002

Jamess-MacBook-Pro:app-designer-2.1.1 jamespotter$ grunt

detected non-Windows environment

Running “server” task

Running “connect:livereload” (connect) task

Started connect web server on http://localhost:8000

Running “open:server” (open) task

Running “watch” task

Waiting…

Hi Caroline,

I have successfully managed to get ODK2 running on Ubuntu on VirtualBox hosted on the same MAC that I am unable to load it on. I followed the same installation steps. On both the MAC & Ubuntu install I can also successfully run the $ grunt adbpush command and connect to the android phone. So it appears that the install documentation works for Ubuntu but there is a problem with MAC loading the ODK2 files.

Is there anyone who may have encountered this problem with MAC OS 10.14.2.?

Many thanks for your help.

James

Hi James,

I’m glad that you got things working in Linux. I was able to get the 2.1.1 Application Designer to work on MacOS 10.14. The messages you see in your terminal align with what I see when I run grunt.

If you could open up the developer tools in Chrome and send the output from
the console that would be helpful. Directions for accessing the console
can be found at https://developers.google.com/web/tools/chrome-devtools/console/.

Thanks,
Clarice

Hi Clarice,

Many thanks for your reply. Please see attached the text file from the Chrome console after I have run $ grunt in the terminal. Is this what you are looking for?

Regards,

James

(Attachment ODK2 Chrome Console is missing)

Hi James,

I did not get the attachment. Please attach the file again. You can also email the log to me at clarlars@gmail.com.

Thanks,
Clarice