ODK Scan app closes when clicking on "Scan New form"

Hello,

I hope you are well and safe.

I am having some difficulties in using the app (ODK-X Scan 2.1.4 rev 234) and I thought you may be able to help me. I have uploaded the templates in the app but as soon as I click on “Scan new form” the app shuts down automatically. Did you face the same problem when using the app? If yes, could you advise me on how to solve this issue?

Thank you in advance for your help and I remain available if you have any other questions.

Many thanks,
Olimpia

1 Like

Hi @OlimpiaLamberti sorry you are having problems. I think @Jeff_Beorse has the most expertise on this – I am afriad I have never used the scan app.

@OlimpiaLamberti are you using version 2.1.4 for the 1) Application Designer, 2) Services, and 3) Survey … also possibly 4) Tables? All the versions should match for compatibility.

Let us know if all the versions are correct it works. I can try to look into another version that might work.

@W_Brunette thank you very much for your suggestion. I was using different versions for the different applications so I just tried downloading the version 2.1.4 for all the application but still it does not work. Could you suggest a version that works?

Many thanks,
Olimpia

1 Like

I have also tried to look for an earlier version of the ODK Scan app but did not find one online. Could you please advise me on where to find one?

Thank you so much for your support.

@OlimpiaLamberti all the releases are on github here: Releases · odk-x/scan · GitHub

Hi @elmps2018, thank you for your message. I have tried to download previous releases from the gitHub page. However, I cannot seem to find the .apk files for the previous releases on the page. In other words, it seems to me that there is the .apk file only for the latest release. Do you know where else I can find these files?

Thanks a lot
Olimpia

@OlimpiaLamberti sorry I don’t know where older .apk files might be – @Jeff_Beorse do you know?

I am a little unclear based on the previous messages if you are looking for previous versions of the other apps or of Scan. Here are links to versions 2.1.4 of each of the apps:

Scan: Release ODK-X Scan v2.1.4 ALPHA · odk-x/scan · GitHub
App Designer: Release ODK-X Application Designer v2.1.4 · odk-x/app-designer · GitHub
Services: Release ODK-X Services 2.1.4 · odk-x/services · GitHub
Survey: Release ODK-X Survey v2.1.4 · odk-x/survey · GitHub
Tables: Release ODK-X Tables v2.1.4 · odk-x/tables · GitHub

Or if you want to look at earlier versions, just look at the “Tags” section under releases in Github. Its probably safest to stick to the number versions (2.x.x) but you can even use the revs (rev 2XX) as long as they all match. Though older versions may have bugs or compatibility issues with modern phones.

Let us know if version 2.1.4 of all the apps still doesn’t work. And note that you will need to generate your forms with App Designer 2.1.4 as well; all of the versions must match.

Going back through the history I see you have been struggling with this for some time now @OlimpiaLamberti. I’m sorry we haven’t been able to help much. I should warn you up front that I don’t think many users have been using Scan for the last couple years so there may be some bugs or compatibility issues that have come up that we are not aware of.

If using all of the v2.1.4 versions of the app doesn’t work, please post your App Designer directory and I will try it out on my computer and see if it works for me. If there is sensitive or confidential information in it, maybe you can make a small test form and we can try that one out.

1 Like

Hi @Jeff_Beorse, thank you for your replies and the links to the different versions of the apps.

As you suggested, I am using version 2.1.4 for the different apps and for generating the form in the App Designer, however the ODK Scan app still shuts when I click on “Scan new form”. I have created a small test form for you to test out with only some of the information we will ask in the survey and I have attached the zip file here. These files get saved in the following directory: / app / config / scan / form_templates /

Let me know if it works for you.

Many thanks for your help,
Olimpia

test1.zip (356.9 KB)

1 Like

Hi @OlimpiaLamberti. Could you actually post the whole config directory? I need the corresponding Survey files that go along with the scan form templates too (formDef.json, definitions.csv etc).

Could you also save your scan form as “Incomplete”? That should output a zip file that it would be helpful to post. I’ll try loading that and running it too. Instructions for how to do that are here: Using ODK-X Scan Form Designer — ODK-X Docs

1 Like

We talked about this in our community call this morning, and it was suggested that you try the latest version that we know was deployed and worked in the field. I think that was rev208. I’ve included the binaries below:

Scan: Release rev208 · odk-x/scan · GitHub
App Designer: Release rev208 · odk-x/app-designer · GitHub
Services: Release rev208 · odk-x/services · GitHub
Survey: Release rev208: Merge branch 'demo' · odk-x/survey · GitHub
Tables: Release rev208 · odk-x/tables · GitHub

If that doesn’t work, lets go back to the plan in my previous post

2 Likes

Hi @Jeff_Beorse,

Thank you for your message and suggestion.
I just have a quick question. For the Scan version rev208, there is no .apk file. I have tried downloading the zip file but I cannot find a .apk file in there. Could you suggest where I can find it?

Thanks,
Olimpia

1 Like

@OlimpiaLamberti we have migrated websites and release processes about 3 times since then and back then the binaries were posted to our website.
You can see the page here on the internet archive Open Data Kit » Downloads

Unfortunately the internet archive does not archive the binaries. You will need to check out and make your own apks for Services, Tables, Survey, and Scan. All the commits are tagged so if you checkout to the tagged version you can create your own binaries.

2 Likes

@OlimpiaLamberti were you able to build the apps yourself? I don’t have the signing key so I’m not sure I can build them for you. But I can help debug if you’re having trouble.

@W_Brunette I wonder if there’s a way we can get Github to host a legacy copy of rev208

1 Like

Hi @Jeff_Beorse, unfortunately I was not able to build the apps myself. I am not too sure on how to do that from @W_Brunette comment above. Would you be able to support be? If yes, would it be possible to schedule a call to show me? I think this will be much easier.

Thanks,
Olimpia

1 Like

@OlimpiaLamberti The readme file for each of the Android projects includes instructions to build them:

Admittedly this is not straightforward at all for someone who doesn’t have a programming background. Scan is particularly difficult.

I could potentially do a call to help out, though I wouldn’t be able to meet until next week. I’m in PDT (UTC-7). What’s your availability? I’m worried this would be difficult even over a call though.

I wonder if @W_Brunette can go back and rebuild the rev208 versions with the official signing key and post them?

1 Like