ODK-X how to debug app designer form?

Hi everyone …
1. What is the problem? Be very detailed.
I am working with ODK-x app-designer-2.1.2. I have a detailed form as well as subform (linked-table) and seem to have made a bad setting/entry in one of the spreadsheets somewhere. Trying to run the from in Chrome results in the form not loading: On the Preview tab in Chrome I click “follow link” then click the form name, then the form returns to “follow link”. It is an endless loop. It may be the “framework.xlsx” form that may be causing this as I was most recently modifying that form.

The main problem is that I don’t have any feedback on what’s wrong. No error message or anything so I don’t know which form to start debugging and which form to modify to try to fix. Is there a way to get debug or error messages from the chrome interface? Perhaps a grunt switch?

2. What app or server are you using and on what device and operating system? Include version numbers.

app-designer-2.1.2 on Ubuntu.

3. What you have you tried to fix the problem?

I removed reference to the subform (changed the linked-table to a select-one-dropdown), in hoping that it was the subform, but the main form still does not load. I also have double checked and modified the framework form … still to no avail. The next step will be to use a ‘clean’ framework form.

4. What steps can we take to reproduce the problem?

Is there way way to get error messages so I know how to make a reproducible example?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

It doesn’t look like upgrading to 2.1.3 will help, but I’m also considering that as a next step.

Finally(!) I seem to have it fully working on a tablet (before I made the bad edit?). Is there a way to replace what is on my computer with what is on my tablet? I have tried just copying back the spreadsheets and running XLSX converter on them but it doesn’t seem to do it.

Thanks for any pointers,

I’ve just made some progress. The model sheet on the main form seems to have been bad. I renamed it and I can open the form again. Progress!

I think I have everything back in order. Lesson learned - I’ve begun tracking changes with git.

edit: getting debug information is discussed here: