ODK2 Sync Endpoint: Authentication error

Hi
I have deployed an ODK Sync Endpoint following instructions on
https://docs.opendatakit.org/odk2/sync-endpoint/
I have created an account kbernardet and on the server I see :

Who Am I?
Username: kbernardet
Full name: kbernardet
Groups and Roles
ROLE_DATA_OWNER
USER_IS_REGISTERED
ROLE_DATA_VIEWER
ROLE_SUPER_USER_TABLES
AUTH_LDAP
ROLE_USER
ROLE_DATA_COLLECTOR
ROLE_SYNCHRONIZE_TABLES
GROUP_TEST

But I have an Authentication error if I use this account on ODK Survey or Tables.
Thanks for any tip

Karim

Hi,

The problem is that your server doesn’t have a TLS certificate and that ODK Services, by default, doesn’t communicate over an unsecure channel.

See https://docs.opendatakit.org/odk2/services-managing#managing-server-settings for the option to enable unsecure communication.

Best,
Li

Got it Thanks

When Syncing I have “Server does not have all app-level or table-level configuration for this APK version. Did you intend to reset the server ?”
In ODK Services, I do not find the button to reset the server.

Got it
Had to restart the services

Dear Karim_Bernardet1,

I have the exact same problem. I was able to login from the web-ui using the user with default_prefix site_admins privileges created with phpldapadmin (See screen shot). However, I was not able to login with the same credential using ODK Services app [ODK-X Services 2.1.6 rev 238]. I need help on this one.

Kindest regards,
Getu

When logging in make sure you switch the the server-sign on credential to ‘Username’ from None (anonymous access). This option can be found in services under server settings.

Thank you W_Brunette. That was very helpful. It worked after unchecking the server sign on credentials under “Manage ability to change server settings”. For some reason it was trying to authenticate with Anonymous access even after you changed after following the steps in the documentation. Thanks a million.