Problem installing on Ubuntu 18.04

I am new to ODK and trying to install ODK Sync Endpoint for the first time, but not getting very far.

What ODK tool and version are you using? And on what device and operating system version?
I am following the steps at https://docs.opendatakit.org/odk2/sync-endpoint/ on a clean install of Ubuntu 18.04 Server and Docker-ce 18.09.0 from the docker.com ubuntu repository.

What steps can we take to reproduce the problem?
I run into the following error messages after running step 2:
Sending build context to Docker daemon 17.41kB
Step 1/13 : FROM maven:3-jdk-8 as compiler
3-jdk-8: Pulling from library/maven
54f7e8ac135a: Pull complete
d6341e30912f: Pull complete
087a57faf949: Pull complete
5d71636fb824: Pull complete
9da6b28682cf: Pull complete
203f1094a1e2: Pull complete
ee38d9f85cf6: Pull complete
7f692fae02b6: Pull complete
eaa976dc543c: Pull complete
8b3d77bd4633: Pull complete
81db3d4ce3e6: Pull complete
d5a6db458c9c: Pull complete
Digest: sha256:955e28c9a64b439591adfd43da77586c8bcd45f51627bf9144e297386c6a6be3
Status: Downloaded newer image for maven:3-jdk-8
—> ce22ba6526c6
Step 2/13 : ARG REPO=https://github.com/opendatakit/sync-endpoint
—> Running in 5e043dfa1154
Removing intermediate container 5e043dfa1154
—> b789dbdc1d4c
Step 3/13 : ARG REPO_BRANCH=master
—> Running in 62f2e999235a
Removing intermediate container 62f2e999235a
—> 6c62f9f39c90
Step 4/13 : RUN git clone -b ${REPO_BRANCH} --single-branch --depth=1 ${REPO} sync
—> Running in 6875b223ae80
Cloning into ‘sync’…
Removing intermediate container 6875b223ae80
—> 311089524311
Step 5/13 : RUN cd /sync/src/main/libs && . /sync/src/main/libs/mvn_local_installs && sed -i “s/odk-mysql-it-settings/odk-container-settings/” /sync/aggregate-mysql/pom.xml && cd /sync && mvn -pl “aggregate-src, odk-container-settings, aggregate-mysql” package && unzip /sync/aggregate-mysql/target/aggregate-mysql-.war -d /ROOT
—> Running in a2087cfb5c07
/bin/sh: 1: cd: can’t cd to /sync/src/main/libs
The command '/bin/sh -c cd /sync/src/main/libs && . /sync/src/main/libs/mvn_local_installs && sed -i “s/odk-mysql-it-settings/odk-container-settings/” /sync/aggregate-mysql/pom.xml && cd /sync && mvn -pl “aggregate-src, odk-container-settings, aggregate-mysql” package && unzip /sync/aggregate-mysql/target/aggregate-mysql-
.war -d /ROOT’ returned a non-zero code: 2

What you have you tried to fix the problem?
Running the same command again uses cached downloads but ends with the same error message. Running step 3 completes all 12 steps without error:
Step 12/12 : EXPOSE 8080
—> Running in 8f30712c22ef
Removing intermediate container 8f30712c22ef
—> b3a947397eac
Successfully built b3a947397eac
Successfully tagged odk/sync-web-ui:latest

We have redone the sync-endpoint build system hopefully fixing some of the issues. More changes are coming but hopefully things will be easier.