Unable to find file: ../config/assets/framework/forms/framework/formDef.json

What is the problem? Please be detailed.
I am new in ODK2. I have downloaded “app-designer-2.1.0” and I have followed all steps from the ODK Documentation. Now I am working with “ODK Application Designer Overview” topic (https://docs.opendatakit.org/odk2/app-designer-overview/).
When I click index.html in the app-designer folder, the webpage gives an error “Unable to find file: …/config/assets/framework/forms/framework/formDef.json”.

What ODK tool and version are you using? And on what device and operating system version?
I am using ODK2 app-designer-2.1.0. And I am using windows 7 PC.

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?
I have searched solution from odk forum, But no solution found.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.
Screenshot attached here.

Hi @Sumonthakur1 and welcome to ODK 2 :slight_smile:

Thanks for all the details describing your challenges! So I am not quite sure why you are clicking on index.html to launch… that may be one of the problems.

I would encourage you, if you are just starting on your ODK2 journey, to check out the slides we made here:

The 02_ ones around I think slide 13 show how to launch the interface where you are having trouble. Also the 08_ ones in the set further down have a lot about the file structure. The error message here is telling me that you don’t have a converted framework file in your directory, so that’s likely the problem, check if the file it names is there or not.

Best,
Caroline

Hi Caroline,

Thank you for your cordial support.
This error has been solved. Now I have started with your slides. It seems very much helpful for me.
Thank you again.

Best,
Sumon