Web-ui/login does not open after restarting docker

I’ve run into this on two instances now, the second after I upgraded my RAM - since I thought that could be the issue. Followed the set up guide closely, and am running Ubuntu 18.04.

After setting up a new user, I went to http://[MY IP]/web-ui/login, and it my credentials did not work. On the second round, I ran again docker stack ls which showed 9 services running. The same as when I ran it the first time in the tutorial. So, I followed the lines of code provided to docker:

docker stack rm syncldap
docker stack deploy -c /root/sync-endpoint-default-setup/docker-compose.yml syncldap

Subsequently, running docker stack ls showed only 7 services. I repeated this a few times, and occasionally one item would fail to be created, but every time that result was repeated, with only 7 services and a non-functional web-ui/login.

I also tried disabling the firewall with ufw disable, but this seemed to have no effect.

Hi @jwrozelle,

Could you provide more detail on how the web-ui is non-functional? What do you see and what’s not working?

If you visit http://[YOUR_IP]/odktables/default/tables what do you see?

1 Like

Thanks for your help @linl33! Sure - I’ve gone through the setup process again with the same result, but this time copied the output & took screenshots along the way - so should have mostly what’s needed.

web-ui/login gives me a time out error. This time looks like I’m getting the nginx 504 error, but there were times when I wasn’t getting even that.

If I got to ./odktables/default/tables, a pop-up asked me for login credentials. Using the credentials I created in phpLDAPadmin, it seems to log me in and give me a blank page that says falsefalse

The only difference from docker ps seems to be that the cert-bot isn’t running after restarting docker (which… I don’t think should matter (?), I might be wrong - but if memory serves, that just updates my certificate). docker stack ls still went from 9 to 7 services.

1 Like

@jwrozelle did you configure Sync-Endpoint with or without HTTPS?

If using HTTPS the deploy command is:

docker stack deploy -c docker-compose.yml -c docker-compose-https.yml syncldap

If using HTTP (NOT HTTPS) the deploy command is:

docker stack deploy -c docker-compose.yml syncldap

1 Like