ODK Tools Setup

I am currently in the process of setting up ODK-X and I have installed OI File Manager, ODK-X Services, ODK-X Survey, and ODK-X Table. But for some odd reason whenever I try to open Survey or Table I get a message saying that I have not installed Services and File Manager. I have tried uninstalling and reinstalling the apks multiple times but that does not seem to be fixing the issue. Is there a step that I am missing?

1 Like

Hello @john7325
There are a number of ways that this can be achieved. A quick one is to go to device settings>apps then locate these apps, click one at a time allow installations from unknown source and then give them the permissions.
The other option is that after installing each, open so that you give the permissions before proceeding to the next.
The other way is to open OI file manager find these other apps under it and install
I hope this helps

1 Like

Are you using Android 11? There is a known issue with Android 11 and version 2.1.7. Version 2.1.8 should be out this coming week that fixes the issue.


Thanks @W_Brunette , it’s a very good notice!!
Can I expect that also the problem with Android 10 (OI File Manager show an error message indicating “no access” will be solved?

Thanks in advance!!

Since OI File manager is a another open source project outside our control we won’t be working on a fix for that. You should ask on their github repo.

In the future we will be investigating replacing OI File Manager with something else, but we want to get version 2.1.8 out this week and we do not want to hold up the fixes in 2.1.8 to figure out our replacement strategy.

1 Like

Ok @W_Brunette , thanks!