Survey not showing the files pushed

After execute grunt adbpush, I have the files in my smartphone, but Survey show no files

**2. Server is my PC (http://localhost:8000/index.html), app is Survey. My PC is running Windows10, and my smartphone is BQ E5 Aquiarius U PLus, with Android 7.1.1 **

3. Using OI File Manager I can see the files in the smartphone; with Survey, I don’t know what I can do.

4. I think the problem is local. Perhaps the same version of phone and Android? I don’t know!

5. Anything else we should know or have?: Other peoples, when follow a course, and doing the same, have not any problem.
If you have a test form or screenshots or logs, attach below.

Welcome to the ODK forum, @aortegon ! We’re glad you’re here. When you get a chance, please introduce yourself on this forum thread. I’d also encourage you to add a real picture as your avatar because it helps build community!

Can you tell us whether the surveys show up in preview in the XLSXconverter? I am also not sure quite what sub-folder you are in, but it may be that the framework is not in the right place or not updated. Check out: https://docs.opendatakit.org/odk-x/build-app/#creating-framework-xlsx

Thanks Caroline!!
Is the first time I use ODK-Survey, so, it never show me any xlsx.
framework.xlsx is updated each time I have a new form, and it is located at
"C:\Users\aortegon\Documents\app-designer-2.1.4\app\config\assets\framework\forms

The file you see in the picture I have attached is not the current framewor.xlsx file, but only a copy of the original. The file I’m using is framework.xlsx, and like the rest of my colleagues, it’s located inside …app/config/assets/framework/forms/

Thank a lot!!
Antonio

To see it’s correctly updated, I attache the framework.xlsx file here.

framework.xlsx (18.0 KB)

Antonio

Thanks for sharing your framework! When you try to convert the surveys and framework in the xlsx-converter, did you receive any errors? Or did they convert okay? You do need to convert both the framework and the surveys.

I have no problem when converting the framework and the xlsx forms, no errors message received, all is OK. I know the need to convert both, the framework each time it’s updated, and the xlsx form I generate.

Thanks a lot, I’m very gratefully for your attention and your rapid answer!!
Antonio

Thanks for the additional info! Some further questions for investigation:
When you look in ODK-tables, are the tables for the surveys there?
Have you tried pushing the example app-designer files to the tablet? Can you see those surveys in survey or tables?
Can you send us a screen shot of what happens when you click survey?

:At wellcome!! Thanks a lot for your adittional effort!

Yes, off course. Files are generated at my PC, and after executing “grunt adbpuhs”, they are in my phobne. It’s look like that:
C:\Users\aortegon\Documents\app-designer-2.1.4\app\config\tables\ej_JJ
C:\Users\aortegon\Documents\app-designer-2.1.4\app\config\tables\ejemplo01
C:\Users\aortegon\Documents\app-designer-2.1.4\app\config\tables\ejemplo02
C:\Users\aortegon\Documents\app-designer-2.1.4\app\config\tables\ejemplo03
… and so on.
You can see the image bellow, that I’ve send, showing the folder for each survey:

Inside each folder, there is other subfolder and the correspondant files. I think it’s correct.

No, I’ve tried only in my phone… Would I have to try in some tablet?

Yes, off course.
I’ll do in a separate message, because I can attach only one picture by message

Thanks another time, and excuse me for the time you are spend!!
Antonio

Yes, off course.

For your not to have to trasnlate, the message in the image says:

  • Select a form to edit
  • There is nothing to show
  • Try obtaning and filling a blank form.

:wink::wink:

Thanks for all this info! So when you say the folders are:
C:\Users\aortegon\Documents\app-designer-2.1.4\app\config\tables\ej_JJ
I am not clear about the sub-folders; the excels should be in:
C:\Users\aortegon\Documents\app-designer-2.1.4\app\config\tables\ej_JJ\forms\ej_JJ

Was this what you meant by sub-folders and files? If not, then this is likely the problem.

Also, sorry if I was not clear, but when you open the ODK-Tables app on the phone, do you see any tables or is it blank like survey?

I show you where are exactly one of the xlsx files; others have a similar structure:


Note.- There is 2 xlsx files but only one is relevant, ej_JJ.xlsx; the other file, ej_JJ_00.xlsx is only a primitive version of the other.

I think it’s all OK.

Yes, exactly!!

Sorry, you’re very clear, the error is mine: you ask me for the ODK-Tables but I’ve answer for ODK-Surveys, excuse me.
ODK-Tables are also blanx, like ODK-Survey. It says “Sin tablas de datos”, that is, “No data tables”

I’m very gratefully with you!! Excuse me my poor english please, it’s not easy to me write english…
Antonio

Thanks for these screen shots! So this does look like the right structure but would suggest to try deleting the collect-forms and extra excels just in case they are confusing the issue.

Did you have the same problem when you re-download the app-designer again and push the one with examples?

For your interest, I show you a phone-capture of ODK-Tables:

@aortegon Thanks for sharing your screenshots and welcome to the community.

The XLSX file is the “human readable” version of the form definition and tables. You need to use the XlsxConverter to convert them into “machine readable” version of “formDef.json”. I do not see any “formDef.json” in your screen shots so I am unable to determine if that is the issue or not.

There is a drop and drag XlsxConverter in app-designer OR you can use the following grunt command “grunt xlsx-convert-all” to covert all the Xlsx files grunt can find.

Thanks @W_Brunette!
I know the need to convert both, the xlsx and the framework file, using xlsx converter. In fact, you can see the correspondent formDef.json in the screenshot I’ve send

I convert all my xlsx files, and the framework.xlsx each time it’s updated…
Thanks!!
@aortegon

To figure out if the problem is specific to your forms or your tablet, can you try to re-download the app-designer again and push the one with examples? Does it open and have surveys and tables?

Have you tried have services resetting configuration so it causes a tables and survey form scan on the device?

Directions:
https://docs.opendatakit.org/odk-x/services-managing/#services-managing-reset-config

OK @elmps2018 I’ll do that and I’ll inform with the result!! Thanks a lot another time!! :wink:

No. I don’t know now how to reset configuration, but I’ll wathc the link you give me!! Thanks @W_Brunette :wink:

@elmps2018 and @W_Brunette, I have good news:
I have not the time to follow yours lasts suggestions, but I think the problem is related to an authentication question. I don’t know why, when I access ODK-Survey in my phone, the username is not blank. When I have access to the general configuration, and I’ve deleted the username, I can synchronize with success, and ODK-Survey show me the files!!
I must confirm that all is OK, but I think the problem is solved. You’ll have news about these questions in the next days when I’ll have time to carefully study and prove with different files!!

Thanks a lot!!